Hướng Dẫn Cấu Hình IPsec Virtual Tunnel Interfaces Trên Router Cisco

IPSEC VIRTUAL TUNNEL INTERFACES TRÊN ROUTER CISCO LÀ GÌ?

IPsec Virtual Tunnel Interfaces (VTIs) trên thiết bị Router Cisco cung cấp loại giao diện có thể định tuyến để kết thúc IPsec tunnel và dễ dàng để xác định bảo vệ giữa các trang để tạo thành mạng lớp phủ. IPsec VTI đơn giản hóa cấu hình IPsec để bảo vệ các liên kết từ xa, hỗ trợ phát đa hướng và đơn giản hóa việc quản lý mạng cũng như cân bằng tải.


CẤU HÌNH IPSEC VIRTUAL TUNNEL INTERFACES TRÊN ROUTER CISCO

Hướng Dẫn Cấu Hình IPsec Virtual Tunnel Interfaces Trên Router Cisco
Hướng Dẫn Cấu Hình IPsec Virtual Tunnel Interfaces Trên Router Cisco

Cấu Hình Static IPsec Virtual Tunnel Interfaces Trên Router Cisco

  Lệnh hoặc Hành động Mục đích
Bước 1 enable

Ví dụ:

Device> enable

 

Bật chế độ đặc quyền EXEC

  • Nhập mật khẩu của bạn nếu được nhắc

 

 

Bước 2 configure terminal

Ví dụ:

Device# configure terminal

 

Vào chế độ cấu hình chung

 

Bước 3 crypto IPsec profile profile-name

Ví dụ:

Device(config)# crypto IPsec profile PROF

 

Xác định các tham số IPsec sẽ được sử dụng để mã hóa IPsec giữa hai thiết bị IPsec và vào chế độ cấu hình cấu hình IPsec.

 

Bước 4 set transform-set transform-set-name [transform-set-name2…transform-set-name6]

Ví dụ:

Device(ipsec-profile)# set transform-set tset

 

Chỉ định những bộ biến đổi nào có thể được sử dụng

 

Bước 5 exit

Ví dụ:

Device(ipsec-profile)# exit

 

Thoát khỏi chế độ cấu hình IPsec và vào chế độ cấu hình chung

 

Bước 6 interface type number

Ví dụ:

Device(config)# interface tunnel 0

 

Chỉ định giao diện mà tunnel sẽ được cấu hình và chuyển sang chế độ cấu hình giao diện.

 

Bước 7 ip address address mask

Ví dụ:

Device(config-if)# ip address 10.1.1.1 255.255.255.0

 

Chỉ định địa chỉ IP và mask.

 

Bước 8 tunnel mode ipsec ipv4

Ví dụ:

Device(config-if)# tunnel mode ipsec ipv4

 

Xác định chế độ cho tunnel.

 

Bước 9 tunnel source interface-type interface-number

Ví dụ:

Device(config-if)# tunnel source loopback 0

 

Chỉ định nguồn tunnel dưới dạng giao diện loopback.

 

Bước 10 tunnel destination ip-address

Ví dụ:

Device(config-if)# tunnel destination 172.16.1.1

 

Xác định địa chỉ IP của đích đến tunnel.

 

Bước 11 tunnel protection IPsec profile profile-name

Ví dụ:

Device(config-if)# tunnel protection IPsec profile PROF

 

Liên kết giao diện tunnel với cấu hình IPsec.

 

Bước 12 end

Ví dụ:

Device(config-if)# end

 

Thoát khỏi chế độ cấu hình giao diện và quay lại chế độ đặc quyền EXEC

 

Cấu Hình BGP Qua IPsec Virtual Tunnel Interfaces Trên Router Cisco

  Lệnh hoặc Hành động Mục đích
Bước 1 router bgp autonomous-system-number

Ví dụ:

Device(config)# router bgp 65510

 

Vào chế độ cấu hình bộ định tuyến và tạo quy trình định tuyến BGP

autonomous-system-number —Số của một hệ thống tự trị xác định bộ định tuyến với các bộ định tuyến BGP khác và gắn thẻ thông tin định tuyến được truyền đi. Số trong phạm vi từ 1 đến 65535.

Trong ví dụ này, bộ định tuyến đầu tiên trong quy trình này được xác định là “65510”.

 

Bước 2 neighbor ip-address remote-as autonomous-system-number

Ví dụ:

Device(config-router)# neighbor 10.1.1.2 remote-as 65511

 

ip-address —Địa chỉ IP của giao diện tunnel của bộ định tuyến lân cận.

autonomous-system-number —Số của một hệ thống tự trị xác định bộ định tuyến của bộ định tuyến thứ 2. Số trong phạm vi từ 1 đến 65535.

 

Bước 3 network network-ip-address mask subnet-mask

Ví dụ:

Device(config-router)# network 2.2.2.0 mask 255.255.255.0

 

network-ip-address—Địa chỉ IP của mạng được quảng bá trong BGP.

subnet-mask—subnet mask of the network advertised in BGP.

Note    Mạng lệnh BGP network command và mask must phải khớp chính xác với một tuyến trong bảng định tuyến để nó được đưa vào BGP và được quảng bá tới các BGP lân cận. Điều này khác với EIGRP, OSPF trong đó câu lệnh mạng “cover” một mạng giao diện và nó sẽ chọn mask từ giao diện.

 

Bước 4 exit

Ví dụ:

Device(config-router)# exit

 

Thoát khỏi chế độ cấu hình bộ định tuyến

 

Bước 5 Nhập các lệnh sau trên thiết bị Router Cisco thứ 2
Bước 6 router bgp autonomous-system-number

Ví dụ:

Device(config)# router bgp 65511

 

Vào chế độ cấu hình bộ định tuyến và tạo quy trình định tuyến BGP.

autonomous-system-number —Số của một hệ thống tự trị xác định bộ định tuyến với các bộ định tuyến BGP khác và gắn thẻ thông tin định tuyến được truyền đi. Số trong phạm vi từ 1 đến 65535.

Trong ví dụ, router thứ hai trong quy trình này được xác định là “65511”.

 

Bước 7 neighbor ip-address remote-as autonomous-system-number

Ví dụ:

Device(config-router)# neighbor 10.1.1.1 remote-as 65510

 

ip-address —Địa chỉ IP của giao diện tunnel của bộ định tuyến lân cận

 

Bước 8 network network-ip-address mask subnet-mask

Ví dụ:

Device(config-router)# network 1.1.1.0 mask 255.255.255.0

 

network-ip-address—Địa chỉ IP của mạng được quảng bá trong BGP. Ví dụ: Địa chỉ IP của giao diện loopback.

subnet-mask—subnet mask của mạng được quảng bá trong BGP.

Note    Sử dụng địa chỉ IP và subnet mask chính xác.

Cấu Hình Dynamic IPsec Virtual Tunnel Interfaces Trên Router Cisco

  Lệnh hoặc Hành động Mục đích
Bước 1 enable

Ví dụ:

Device> enable

 

Bật chế độ đặc quyền EXEC

  • Nhập mật khẩu của bạn nếu được nhắc

 

Bước 2 configure terminal

Ví dụ:

Device# configure terminal

 

Vào chế độ cấu hình chung

 

Bước 3 crypto ipsec profile profile-name

Ví dụ:

Device(config)# crypto ipsec profile PROF

 

Xác định các tham số IPsec sẽ được sử dụng để mã hóa IPsec giữa hai thiết bị IPsec và chuyển sang chế độ cấu hình cấu hình IPsec.

 

Bước 4 set transform-set transform-set-name [transform-set-name2…transform-set-name6]

Ví dụ:

Device(ipsec-profile)# set transform-set tset

 

Chỉ định bộ biến đổi nào có thể được sử dụng với mục nhập crypto map.

 

Bước 5 exit

Ví dụ:

Device(ipsec-profile)# exit

 

Thoát khỏi chế độ cấu hình IPsec và vào chế độ cấu hình chung

 

Bước 6 interface virtual-template number type tunnel

Ví dụ:

Device(config)# interface virtual-template 2 type tunnel

 

Xác định giao diện virtual-template tunnel và vào chế độ cấu hình giao diện.

 

Bước 7 tunnel mode ipsec ipv4

Ví dụ:

Device(config-if)# tunnel mode ipsec ipv4

 

Xác định chế độ cho tunnel

 

Bước 8 tunnel protection IPsec profile profile-name

Ví dụ:

Device(config-if)# tunnel protection ipsec profile PROF

 

Liên kết giao diện tunnel với cấu hình IPsec.

 

Bước 9 exit

Ví dụ:

Device(config-if)# exit

 

Thoát khỏi chế độ cấu hình giao diện

 

Bước 10 crypto isakamp profile profile-name

Ví dụ:

Device(config)# crypto isakamp profile profile1

 

Xác định cấu hình ISAKMP sẽ được sử dụng cho mẫu ảo.

 

Bước 11 match identity address ip-address mask

Ví dụ:

Device(conf-isa-prof)# match identity address 10.1.1.0 255.255.255.0

 

So khớp danh tính từ cấu hình ISAKMP và chuyển sang chế độ cấu hình isakmp-profile.

 

Bước 12 virtual template template-number

Ví dụ:

Device(config)# virtual-template 1

 

Chỉ định mẫu ảo được đính kèm với cấu hình ISAKMP.

 

Bước 13 end

Ví dụ:

Device(config)# end

 

Thoát khỏi chế độ cấu hình chung và vào chế độ EXEC đặc quyền

 

Cấu Hình Hỗ Trợ Multi-SA Cho IPsec Virtual Tunnel Interfaces Bằng IKEv1 Trên Router Cisco

  Lệnh hoặc Hành động Mục đích
Bước 1 enable

Ví dụ:

Device> enable 

 

Bật chế độ EXEC đặc quyền

 

Bước 2 configure terminal

Ví dụ:

Device# configure terminal

 

Vào chế độ cấu hình chung
Bước 3 ip vrf vrf-name

Ví dụ:

Device(config)# ip vrf VRF-100-1

 

Xác định phiên bản VRF và vào chế độ cấu hình VRF.
Bước 4 rd route-distinguisher

Ví dụ:

Device(config-vrf)# rd 100:21

 

Tạo bảng định tuyến và chuyển tiếp cho VRF.

 

Bước 5 exit

Ví dụ:

Device(config-vrf)# exit

 

Thoát khỏi chế độ cấu hình VRF và vào chế độ cấu hình chung.
Bước 6 crypto keyring keyring-name

Ví dụ:

Device(config)# crypto keyring cisco-100-1

 

Xác định vòng khóa crypto key ring và vào chế độ cấu hình key ring.
Bước 7 pre-shared-key address key key

Ví dụ:

Device(config-keyring)# pre-shared-key address 10.1.1.1 key cisco-100-1

 

Xác định khóa chia sẻ trước sẽ được sử dụng để xác thực Internet Key Exchange (IKE).
Bước 8 exit

Ví dụ:

Device(config-keyring)# exit

 

Thoát khỏi chế độ cấu hình keyring và vào chế độ cấu hình chung.
Bước 9 crypto isakmp profile profile-name

Ví dụ:

Device(config)# crypto isakmp profile

cisco-isakmp-profile-100-1

 

Xác định cấu hình ISAKMP và vào chế độ cấu hình ISAKMP.
Bước 10 keyring keyring-name

Ví dụ:

Device(conf-isa-prof)# keyring cisco-100-1

 

Cấu hình key ring ở chế độ ISAKMP.
Bước 11 match identity address mask

Ví dụ:

Device(conf-isa-prof)# match identity address 10.1.1.0 255.255.255.0

 

So khớp danh tính từ hồ sơ ISAKMP.
Bước 12 virtual-template template-number

Ví dụ:

Device(conf-isa-prof)# virtual-template 101

 

Chỉ định mẫu ảo sẽ được sử dụng để sao chép các giao diện truy cập ảo.
Bước 13 exit

Ví dụ:

Device(conf-isa-prof)# exit

 

Thoát khỏi chế độ cấu hình ISAKMP profile và vào chế độ cấu hình chung.
Bước 14 crypto ipsec transform-set transform-set-name transform1 [transform2] [transform3]

Ví dụ:

Device(config)# crypto ipsec transform-set cisco esp-aes esp-sha-hmac

 

Xác định bộ biến đổi và vào chế độ cấu hình biến đổi crypto
Bước 15 exit

Ví dụ:

Device(conf-crypto-trans)# exit

 

Thoát khỏi chế độ cấu hình biến đổi crypto và vào chế độ cấu hình chung.
Bước 16 crypto ipsec profile name

Ví dụ:

Device(config)# crypto ipsec profile cisco-ipsec-profile-101

 

Xác định các tham số IPsec được sử dụng để mã hóa IPsec giữa hai thiết bị IPsec và vào chế độ cấu hình IPsec.
Bước 17 set security-policy limit maximum-limit

Ví dụ:

Device(ipsec-profile)# set security-policy limit 3

 

Xác định giới hạn trên đối với số luồng có thể được tạo cho một giao diện truy cập ảo riêng lẻ.
Bước 18 set transform-set transform-set-name [transform-set-name2 …. transform-set-name6]

Ví dụ:

Device(ipsec-profile)# set transform-set cisco

 

Chỉ định các bộ biến đổi sẽ được sử dụng với mục nhập crypto map.
Bước 19 exit

Ví dụ:

Device(ipsec-profile)# exit

 

Thoát khỏi cấu hình IPsec và vào chế độ cấu hình chung.
Bước 20 interface virtual-template number type tunnel

Ví dụ:

Device(config)# interface virtual-template 101 type tunnel

 

Tạo một giao diện mẫu ảo có thể được cấu hình giao diện và vào chế độ cấu hình giao diện
Bước 21 ip vrf forwarding vrf-name

Ví dụ:

Device(config-if)# ip vrf forwarding VRF-100-1

 

Liên kết phiên bản VRF với virtual-template interface.
Bước 22 ip unnumbered type number

Ví dụ:

Device(config-if)# ip unnumbered GigabitEthernet 0.0

 

Cho phép xử lý IP trên giao diện mà không cần gán địa chỉ IP cho giao diện
Bước 23 tunnel mode ipsec ipv4

Ví dụ:

Device(config-if)# tunnel mode ipsec ipv4

 

Xác định chế độ cho tunnel.

 

Bước 24 tunnel protection profile ipsec profile-name

Ví dụ:

Device(config-if)# tunnel protection ipsec profile PROF

 

Liên kết giao diện tunnel với cấu hình IPsec.
Bước 25 end

Ví dụ:

Device(config-if)# end

 

Thoát khỏi chế độ cấu hình giao diện và quay lại chế độ đặc quyền EXEC.

Cấu Hình Hỗ Trợ Chế Độ IPsec Mixed Cho SVTIs Trên Router Cisco

  Lệnh hoặc Hành động Mục đích
Bước 1 enable

Ví dụ:

Device> enable

 

Bật chế độ EXEC đặc quyền

  • Nhập mật khẩu của bạn nếu được nhắc
Bước 2 configure terminal

Ví dụ:

Device# configure terminal

 

Vào chế độ cấu hình chung

 

Bước 3 crypto IPsec profile profile-name

Ví dụ:

Device(config)# crypto IPsec profile PROF

 

Xác định các tham số IPsec sẽ được sử dụng cho để mã hóa IPsec giữa hai thiết bị IPsec và vào chế độ cấu hình cấu hình IPsec.

 

Bước 4 set transform-set transform-set-name [transform-set-name2…transform-set-name6]

Ví dụ:

Device(ipsec-profile)# set transform-set tset

 

Chỉ định bộ biến đổi nào có thể được sử dụng với mục nhập crypto map.

 

Bước 5 exit

Ví dụ:

Device(ipsec-profile)# exit

 

Thoát khỏi chế độ cấu hình IPsec profile và vào chế độ cấu hình chung

 

Bước 6 interface type number

Ví dụ:

Device(config)# interface tunnel 0

 

Chỉ định giao diện mà tunnel sẽ được cấu hình và chuyển sang chế độ cấu hình giao diện.

 

Bước 7 ip address address mask

Ví dụ:

Device(config-if)# ip address 10.1.1.1 255.255.255.0

 

Chỉ định địa chỉ IP và mask.

 

Bước 8 Thực hiện một trong các lệnh sau:

·        tunnel mode ipsec ipv4 v6-overlay

·        tunnel mode ipsec ipv6 v4-overlay

Ví dụ:

Device(config-if)# tunnel mode ipsec ipv4 v6-overlay

 

Xác định chế độ tunnel.

 

Bước 9 tunnel source interface-type interface-type

Ví dụ:

Device(config-if)# tunnel source loopback 0

 

Chỉ định nguồn tunnel dưới dạng giao diện loopback.

 

Bước 10 tunnel destination ip-address

Ví dụ:

Device(config-if)# tunnel destination 172.16.1.1

 

Xác định địa chỉ IP của đích đến tunnel

 

Bước 11 tunnel protection IPsec profile profile-name

Ví dụ:

Device(config-if)# tunnel protection IPsec profile PROF

 

Liên kết giao diện tunnel với cấu hình IPsec

 

Bước 12 end

Ví dụ:

Device(config-if)# end

 

Thoát khỏi chế độ cấu hình giao diện và quay lại chế độ EXEC đặc quyền

 

Cấu Hình Hỗ Trợ Chế Độ IPsec Mixed Cho Dynamic VTIs Trên Router Cisco

  Lệnh hoặc Hành động Mục đích
Bước 1 enable

Ví dụ:

Device> enable

 

Bật chế độ EXEC đặc quyền

  • Nhập mật khẩu của bạn nếu được nhắc

 

Bước 2 configure terminal

Ví dụ:

Device# configure terminal

 

Vào chế độ cấu hình chung

 

Bước 3 crypto ipsec profile profile-name

Ví dụ:

Device(config)# crypto ipsec profile PROF

 

Xác định các tham số IPsec sẽ được sử dụng để mã hóa IPsec giữa hai thiết bị IPsec và chuyển sang chế độ cấu hình cấu hình IPsec.

 

Bước 4 set mixed mode

Ví dụ:

Device(config)# set mixed mode

 

Xác định các tham số IPsec sẽ được sử dụng để mã hóa IPsec giữa hai thiết bị IPsec và chuyển sang chế độ cấu hình cấu hình IPsec.

 

Bước 5 set transform-set transform-set-name [transform-set-name2…transform-set-name6]

Ví dụ:

Device(ipsec-profile)# set transform-set tset

 

Chỉ định bộ biến đổi nào có thể được sử dụng với mục nhập crypto map

 

Bước 6 exit

Ví dụ:

Device(ipsec-profile)# exit

 

Thoát khỏi chế độ cấu hình cấu hình ipsec và vào chế độ cấu hình chung.

 

Bước 7 interface virtual-template number type tunnel

Ví dụ:

Device(config)# interface virtual-template 2 type tunnel

 

Xác định giao diện virtual-template tunnel interface và vào chế độ cấu hình giao diện

 

Bước 8 tunnel mode ipsec ipv4

Ví dụ:

Device(config-if)# tunnel mode ipsec ipv4

 

Xác định chế độ cho tunnel.

 

Bước 9 tunnel protection IPsec profile profile-name

Ví dụ:

Device(config-if)# tunnel protection ipsec profile PROF

 

Liên kết giao diện tunnel với IPsec profile.

 

Bước 10 exit

Ví dụ:

Device(config-if)# exit

 

Thoát khỏi chế độ cấu hình giao diện

 

Bước 11 crypto isakamp profile profile-name

Ví dụ:

Device(config)# crypto isakamp profile profile1

 

Xác định cấu hình ISAKMP sẽ được sử dụng cho mẫu virtual.

 

Bước 12 match identity address ip-address mask

Ví dụ:

Device(conf-isa-prof)# match identity address 10.1.1.0 255.255.255.0

 

So khớp danh tính từ ISAKMP profile và chuyển sang chế độ cấu hình isakmp-profile.

 

Bước 13 virtual template template-number

Ví dụ:

Device(config)# virtual-template 1

 

Chỉ định mẫu virtual được đính kèm với ISAKMP profile.

 

Bước 14 end

Ví dụ:

Device(config)# end

 

Thoát khỏi chế độ cấu hình chung và vào chế độ đặc quyền EXEC.

 


ĐỊA CHỈ PHÂN PHỐI ROUTER CISCO CHÍNH HÃNG GIÁ TỐT NHẤT

ANBINHNET ™ là nhà phân phối Cisco chính hãng, uy tín hàng đầu tại Việt Nam. Đến với chúng tôi, quý khách hàng sẽ nhận được những thông tin chính xác về nguồn gốc xuất xứ, giấy tờ, chứng chỉ, với mức giá Discount theo quy định của Cisco, đặc biệt hơn là hàng luôn sẵn kho số lượng lớn để đáp ứng nhu cầu của khách hàng.

ANBINHNET ™ có văn phòng giao dịch tại 2 thành phố lớn nhất là Hà Nội và Hồ Chí Minh (Sài Gòn), giúp mang lại sự thuận tiện cho khách hàng có nhu cầu mua thiết bị Router Cisco Chính Hãng có thể đến trực tiếp văn phòng của chúng tôi, cũng như rút ngắn thời gian giao hàng các sản phẩm Cisco Router Giá Tốt đến với khách hàng.

Để Nhận Thông Tin Hỗ Trợ Báo Giá Dự Án, Đặt Hàng, Giao Hàng, Bảo Hành, Khuyến Mại, Hỗ Trợ Kỹ Thuật của các sản phẩm Router CiscoHãy Chát Ngay với chúng tôi ở khung bên dưới hoặc gọi điện tới số hotline hỗ trợ 24/7 của ANBINHNET ™. Hoặc quý khách có thể liên hệ tới văn phòng của chúng tôi tại theo thông tin sau:

Địa Chỉ Phân Phối Router Cisco Chính Hãng Giá Tốt Tại Hà Nội

Địa Chỉ Phân Phối Router Cisco Chính Hãng Giá Tốt Tại Sài Gòn

Trả lời

Email của bạn sẽ không được hiển thị công khai. Các trường bắt buộc được đánh dấu *

HOTLINE 24/7: 098.234.5005 - 0967.40.70.80