Hướng Dẫn Cấu Hình Easy Virtual Network Trên Router Cisco

EASY VIRTUAL NETWORK LÀ GÌ?

Easy Virtual Network (EVN) là công nghệ ảo hóa dựa trên IP cung cấp khả năng đầu cuối của hai hoặc nhiều mạng Layer 3. Bạn có thể sử dụng một cơ sở hạ tầng IP duy nhất để cung cấp các mạng ảo riêng biệt có đường dẫn lưu lượng vẫn được tách biệt với nhau.

EVN xây dựng trên cơ chế ảo hóa dựa trên IP hiện có được gọi là VRF-Lite. EVN cung cấp các cải tiến trong cách ly đường dẫn, đơn giản hóa cấu hình và quản lý cũng như hỗ trợ dịch vụ chia sẻ được cải thiện. EVN tương thích ngược với VRF-Lite để cho phép di chuyển mạng liền mạch từ VRF-Lite sang EVN.

EVN hỗ trợ IPv4, định tuyến tĩnh, Open Shortest Path First phiên bản 2 (OSPFv2) và Giao thức định tuyến cổng nội bộ nâng cao (EIGRP) cho định tuyến unicast và Giao thức đa hướng độc lập giao thức (PIM) và Giao thức khám phá nguồn đa hướng (MSDP) cho định tuyến đa hướng IPv4. EVN cũng hỗ trợ Cisco Express Forwarding (CEF) và Giao thức quản lý mạng đơn giản (SNMP).

EVN mang đến những lợi ích bao gồm:

  • Hạn chế quyền truy cập mạng của khách vào Internet, sử dụng đường dẫn dữ liệu được xác định trước thông qua mạng của khách hàng và có thể xác định tuyến đường mặc định duy nhất cho lưu lượng truy cập của khách.
  • Cô lập lưu lượng truy cập bắt nguồn từ một máy tính để bàn không tuân thủ.
  • Hạn chế các đối tác và nhà thầu truy cập vào các dịch vụ dùng chung của mạng, chẳng hạn như Internet, e-mail, DNS, DHCP hoặc máy chủ ứng dụng.
  • Bảo mật các dịch vụ và thiết bị bằng cách “bắt buộc” lưu lượng truy cập vào một tường lửa tập trung nơi lưu lượng truy cập phải được kiểm tra.
  • Tách lưu lượng dữ liệu của các khách hàng khác nhau.
  • Hạn chế một phần của mạng đối với lưu lượng truy cập yêu cầu mức dịch vụ rất nghiêm ngặt, có thể giảm chi phí bằng cách chỉ cung cấp những yêu cầu đó khi cần.
  • Hợp nhất các công ty hoặc mạng theo từng giai đoạn, đồng thời cho phép họ chia sẻ dịch vụ, khi cần thiết.
  • Yêu cầu một mạng riêng biệt dưới một cơ quan duy nhất cho các nhóm tự trị.

Với những lợi ích vừa được liệt kê ở trên, tính năng EVN là vô cùng cần thiết với các thiết bị Router Cisco. Sau đây, quản trị viên của ANBINHNET ™ sẽ gửi đến quý khách hướng dẫn cấu hình EVN trên các thiết bị Router Cisco.


CÁC BƯỚC CẤU HÌNH EASY VIRTUAL NETWORK TRÊN ROUTER CISCO

Cấu Hình EVN Trên Router Cisco
Cấu Hình EVN Trên Router Cisco

Cấu Hình Easy Virtual Network Trunk Interface Cho Router Cisco

Đầu tiên, hãy bắt đầu để cấu hình giao diện Easy Virtual Network Trunk. Giao diện này kết nối các bộ định tuyến Cisco để cung cấp lõi để vận chuyển lưu lượng cho nhiều mạng ảo. Lưu lượng được truyền qua giao diện trung kế được gắn thẻ. Phần này minh họa cách định cấu hình giao diện trung kế với VRF và hai VRF có tên: VRF red và VRF blue.

Các bước chi tiết để cấu hình giao diện Easy Virtual Network Trunk được thể hiện trong bảng dưới đây:

  Lệnh hoặc Hành động Mục đích
Bước 1 enable

Ví dụ:

Router> enable

 

Bật chế độ EXEC đặc quyền.

  • Nhập mật khẩu của bạn nếu được nhắc

 

Bước 2 configure terminal

Ví dụ:

Router# configure terminal

 

Vào chế độ cấu hình chung.

 

Bước 3 vrf definition vrf-name

Ví dụ:

Router(config)# vrf definition red

 

Cấu hình phiên bản bảng định tuyến VRF và vào chế độ cấu hình VRF

 

Bước 4 vnet tag number

Ví dụ:

Router(config-vrf)# vnet tag 100

 

Chỉ định số thẻ toàn cầu cho VRF.

  • Số thẻ giống nhau phải được cấu hình cho cùng một mạng ảo trên mỗi giao diện edge và trunk

 

Bước 5 description string

Ví dụ:

Router(config-vrf)# description guest access

 

(Tùy chọn) Mô tả VRF để giúp quản trị viên xem lại các file cấu hình

 

Bước 6 address-family ipv4

Ví dụ:

Router(config-vrf)# address-family ipv4

 

Vào chế độ cấu hình address family để định cấu hình phiên định tuyến bằng các tiền tố địa chỉ IPv4 tiêu chuẩn

 

Bước 7 exit-address-family

Ví dụ:

Router(config-vrf-af)# exit-address-family

 

Thoát khỏi chế độ cấu hình address family

 

Bước 8 exit

Ví dụ:

Router(config-vrf)# exit

 

Thoát khỏi chế độ cấu hình chung

 

Bước 9 vrf definition vrf-name

Ví dụ:

Router(config)# vrf definition blue

 

Cấu hình phiên bản bảng định tuyến VRF và vào chế độ cấu hình VRF

 

Bước 10 vnet tag number

Ví dụ:

Router(config-vrf)# vnet tag 200

 

Chỉ định số thẻ toàn cầu cho VRF

  • Số thẻ giống nhau phải được cấu hình cho cùng 1 VRF trên mỗi giao diện edge và trunk

 

Bước 11 description string

Ví dụ:

Router(config-vrf) description Finance

 

(Tùy chọn) Mô tả VRF để giúp quản trị viên mạng xem xét các file cấu hình

 

Bước 12 address-family ipv4

Ví dụ:

Router(config-vrf) address-family ipv4

 

Vào chế độ cấu hình address family để định cấu hình phiên định tuyến bằng các tiền tố địa chỉ IPv4 tiêu chuẩn

 

Bước 13 exit-address-family

Ví dụ:

Router(config-vrf-af) exit-address-family

 

Thoát khỏi chế độ cấu hình address family.

 

Bước 14 exit

Ví dụ:

Router(config-vrf)# exit

 

Thoát khỏi chế độ cấu hình chung.

 

Bước 15 interface type number

Ví dụ:

Router(config)# interface gigabitethernet 1/1/1

 

Cấu hình một kiểu giao diện và vào chế độ cấu hình giao diện.
Bước 16 ip address ip-address mask

Ví dụ:

Router(config-if)# ip address 10.1.1.1 255.255.255.0

 

Đặt địa chỉ IP chính cho giao diện.
Bước 17 vnet trunk [list vrf-list-name]

Ví dụ:

Router(config-if)# vnet trunk

 

Xác định một giao diện trunk

  • Theo mặc định, tất cả các VRF được xác định bằng lệnh vrf definition chạy trên tất cả các giao diện trung kế trên bộ định tuyến Cisco. Do đó, VRF red và VRF xanh hiện đang chạy trên giao diện này.
  • Sử dụng lệnh list vrf-list-name để hạn chế VRF chạy trên giao diện trunk
Bước 18 vnet name vrf-name

Ví dụ:

Router(config-if)# vnet name red

 

(Tùy chọn) Vào chế độ virtual network interface để cấu hình các tính năng áp dụng cho VRF được chỉ định để ghi đè các giá trị VRF chung

  • Bước này không cần thiết nếu cài đặt chung được áp dụng cho tất cả các VRF trên giao diện
  • Sau bước này, bạn định cấu hình một hoặc nhiều lệnh đủ điều kiện

 

Bước 19 exit-if-vnet

Ví dụ:

Router(config-if-vnet) exit-if-vnet

 

Thoát khỏi chế độ cấu hình giao diện VRF và vào chế độ cấu hình giao diện.

 

Bước 20 no shutdown

Ví dụ:

Router(config-if) no shutdown

 

Khởi động lại một giao diện.

 

Bước 21 exit

Ví dụ:

Router(config-if) exit

 

Thoát khỏi chế độ cấu hình chung

 

Bước 22 router ospf process-id

Ví dụ:

Router(config)# router ospf 1

 

Cấu hình quy trình định tuyến Open Shortest Path First (OSPF) và liên kết nó với VRF.

  • Phiên bản OSPF này không có VRF, vì vậy nó là vnet global.

 

Bước 23 network ip-address wildcard area area-id

Ví dụ:

Router(config-router) network 10.0.0.0 255.255.255.0 area 0

 

Xác định các giao diện và ID khu vực liên quan mà OSPF chạy trên đó.

 

Bước 24 exit

Ví dụ:

Router(config-router) exit

 

Thoát khỏi chế độ cấu hình chung.

 

Bước 25 router ospf process-id vrf vrf-name

Ví dụ:

Router(config)# router ospf 2 vrf red

 

Định cấu hình quy trình định tuyến OSPF và liên kết nó với VRF

  • Chỉ định một process-id khác nhau cho mỗi VRF bởi vì mỗi VRF đều cần phiên bản OSPF của riêng mình.

 

Bước 26 network ip-address wildcard area area-id

Ví dụ:

Router(config-router) network 10.0.0.0 255.255.255.0 area 0

 

Xác định các giao diện và ID khu vực liên quan mà OSPF chạy trên đó và ID khu vực cho các giao diện đó.

 

Bước 27 exit

Ví dụ:

Router(config-router) exit

 

Thoát khỏi chế độ cấu hình chung.

 

Bước 28 router ospf process-id vrf vrf-name

Ví dụ:

Router(config)# router ospf 3 vrf blue

 

Cấu hình quy trình định tuyến OSPF và liên kết nó với VRF.

  • Chỉ định một process-id khác nhau cho mỗi VRF bởi vì mỗi VRF đều cần phiên bản OSPF của riêng mình.

 

Bước 29 network ip-address wildcard area area-id

Ví dụ:

Router(config-router) network 10.0.0.0 255.255.255.0 area 2

 

Xác định các giao diện và ID khu vực liên quan mà OSPF chạy trên đó và ID khu vực cho các giao diện đó.

 

Bước 30 end

Ví dụ:

Router(config-vrf) end

 

Kết thúc phiên cấu hình và quay lại chế độ EXEC đặc quyền.

 

Kích Hoạt Một Tập Hợp Con VRF Trên Giao Diện Trunk Cho Router Cisco

Theo mặc định, các giao diện trunk trên Router Cisco có thể mang lưu lượng cho từng VRF được xác định bởi lệnh vrf definition. Tuy nhiên, bạn có thể chỉ muốn bật một tập hợp con VRF trên giao diện trung kế, điều này được thực hiện bằng cách tạo danh sách VRF. Có thể tồn tại tối đa 32 danh sách VRF trên một bộ định tuyến Cisco. Thực hiện tác vụ sau để tạo danh sách VRF. Tác vụ này giả định rằng VRF đã được cấu hình.

Các bước chi tiết để kích hoạt một tập hợp con VRF trên giao diện Trunk cho Router Cisco

  Lệnh hoặc Hành động Mục đích
Bước 1 enable

Ví dụ:

Router> enable

 

Bật chế độ EXEC đặc quyền

  • Nhập mật khẩu của bạn nếu được nhắc

 

Bước 2 configure terminal

Ví dụ:

Router# configure terminal

 

Vào chế độ cấu hình chung

 

Bước 3 vrf list vrf-list-name

Ví dụ:

Router(config)# vrf list External

 

Xác định danh sách VRF và vào chế độ cấu hình danh sách VRF

  • Đối số vrf-list-name có thể chứa tối đa 32 ký tự. Dấu ngoặc kép, dấu cách và dấu * không được phép.

 

Bước 4 member vrf-name

Ví dụ:

Router(config-vrf-list)# member blue

 

Chỉ định VRF hiện tại là thành viên của danh sách VRF

  • VRF phải được xác định trước khi nó có thể được thêm vào danh sách

 

Bước 5 Repeat Step 4 to add other VRFs to the list.   (Tùy chọn) Nếu bạn muốn giao diện trung kế với một VRF, danh sách của bạn chỉ cần một VRF.

 

Bước 6 exit-vrf-list

Ví dụ:

Router(config-vrf-list)# exit-vrf-list

 

Thoát khỏi chế độ cấu hình danh sách VRF.

 

Bước 7 interface type number

Ví dụ:

Router(config)# interface gigabitethernet 1/1/1

 

Định cấu hình giao diện và vào chế độ cấu hình giao diện.
Bước 8 vnet trunk list vrf-list-name

Ví dụ:

Router(config-if)# vnet trunk list mylist

 

Xác định giao diện đường trục và kích hoạt các VRF trong danh sách VRF.

  • Sử dụng vrf-list-name được xác định trong Bước 3

 

Bước 9 ip address ip-address mask

Ví dụ:

Router(config-if)# ip address 10.1.3.1 255.255.255.0

 

Đặt địa chỉ IP chính cho giao diện.
Bước 10 end

Ví dụ:

Router(config-if) end

 

Kết thúc phiên cấu hình và quay lại chế độ EXEC đặc quyền.

 

Bước 11 show vrf list [vrf-list-name]

Ví dụ:

Router# show vrf list mylist

 

Hiển thị thông tin về danh sách VRF.

Cấu Hình Giao Diện Edge EVN Trên Router Cisco

Thực hiện tác vụ này để cấu hình giao diện Edge, giao diện này kết nối thiết bị người dùng với mạng ảo. Lưu lượng được truyền qua giao diện Edge không được gắn thẻ. Giao diện edge xác định lưu lượng nhận được thuộc về mạng ảo nào. Mỗi giao diện Edge chỉ được ánh xạ tới một mạng ảo.

Dưới đây là các bước chi tiết để cấu hình giao diện EVN Edge trên Router Cisco

  Lệnh hoặc Hành động Mục đích
Bước 1 enable

Ví dụ:

Router> enable

 

Bật chế độ EXEC đặc quyền

  • Nhập mật khẩu của bạn nếu được nhắc

 

Bước 2 configure terminal

Ví dụ:

Router# configure terminal

 

Vào chế độ cấu hình chung.

 

Bước 3 interface type number

Ví dụ:

Router(config)# interface gigabitethernet 1/0/0

 

Cấu hình một kiểu giao diện và vào chế độ cấu hình giao diện.

 

Bước 4 vrf forwarding vrf-name

Ví dụ:

Router(config-if)# vrf forwarding red

 

Xác định giao diện edge và xác định VRF chứa lưu lượng đến

  • vrf-name phải được xác định bằng lệnh vrf definition
  • Trong ví dụ này, lưu lượng đến thuộc VRF red
Note    Đảm bảo bạn không ở trên giao diện trunk khi bạn đang cố định cấu hình giao diện edge 

 

Bước 5 ip address ip-address mask

Ví dụ:

Router(config-if)# ip address 10.1.1.1 255.255.255.0

 

Đặt địa chỉ IP chính cho giao diện.
Bước 6 end

Ví dụ:

Router(config-if) end

 

Kết thúc phiên cấu hình và quay lại chế độ EXEC đặc quyền.

Xác Thực Cấu Hình EVN Trên Router Cisco

Thực hiện bất kỳ bước nào sau đây trong tác vụ này để xác minh cấu hình của bạn. Vì mạng ảo là một VRF nên tất cả các lệnh show VRF hiện có đều được hỗ trợ cho mạng ảo. Nếu một bộ định tuyến có sự kết hợp giữa VRF và mạng ảo, thì các lệnh show vrf khác nhau sẽ bao gồm cả VRF và mạng ảo ở đầu ra.

Các bước chi tiết để xác thực cấu hình EVN trên Router Cisco

  Lệnh hoặc Hành động Mục đích
Bước 1 enable

Ví dụ:

Router> enable

 

Bật chế độ EXEC đặc quyền.

  • Nhập mật khẩu nếu được nhắc

 

Bước 2 show vnet tag

Ví dụ:

Router# show vnet tag

 

(Tùy chọn) Hiển thị nơi mỗi thẻ đã được cấu hình hoặc sử dụng
Bước 3 show running-config [vrf | vnet] [vrf-name]

Ví dụ:

Router# show running-config vrf green

 

(Tùy chọn) Hiển thị VRF trong cấu hình đang chạy, hiển thị giao diện trong VRF và hiển thị cấu hình giao thức cho Multi-VRF
Bước 4 show vrf list [vrf-list-name]

Ví dụ:

Router# show vrf list

 

(Tùy chọn) Hiển thị thông tin về danh sách VRF, chẳng hạn như VRF trong mỗi danh sách.
Bước 5 show {vrf | vnet} [ipv4 | ipv6] [interface | brief | detail | lock] [vrf-name]

Ví dụ:

Router# show vnet detail

 

(Tùy chọn) Hiển thị thông tin về VRF
Bước 6 show {vrf | vnetcounters

Ví dụ:

Router# show vnet counters

 

(Tùy chọn) Hiển thị thông tin về số lượng VRF hoặc mạng ảo được hỗ trợ và định cấu hình

ĐỊA CHỈ PHÂN PHỐI ROUTER CISCO CHÍNH HÃNG GIÁ TỐT NHẤT

ANBINHNET ™ là nhà phân phối Cisco Việt Nam chính hãng, uy tín hàng đầu tại Việt Nam. Đến với chúng tôi, quý khách hàng sẽ nhận được những thông tin chính xác về nguồn gốc xuất xứ, giấy tờ, chứng chỉ, với mức giá Discount theo quy định của Cisco, đặc biệt hơn là hàng luôn sẵn kho số lượng lớn để đáp ứng nhu cầu của khách hàng.

ANBINHNET ™ có văn phòng giao dịch tại 2 thành phố lớn nhất là Hà Nội và Hồ Chí Minh (Sài Gòn), giúp mang lại sự thuận tiện cho khách hàng có nhu cầu mua thiết bị Router Cisco Chính Hãng có thể đến trực tiếp văn phòng của chúng tôi, cũng như rút ngắn thời gian giao hàng các sản phẩm Cisco Router Giá Tốt đến với khách hàng.

Để Nhận Thông Tin Hỗ Trợ Báo Giá Dự Án, Đặt Hàng, Giao Hàng, Bảo Hành, Khuyến Mại, Hỗ Trợ Kỹ Thuật của các sản phẩm Router CiscoHãy Chát Ngay với chúng tôi ở khung bên dưới hoặc gọi điện tới số hotline hỗ trợ 24/7 của ANBINHNET ™. Hoặc quý khách có thể liên hệ tới văn phòng của chúng tôi tại theo thông tin sau:

Địa Chỉ Phân Phối Router Cisco Chính Hãng Giá Tốt Tại Hà Nội

Địa Chỉ Phân Phối Router Cisco Chính Hãng Giá Tốt Tại Sài Gòn

Trả lời

Email của bạn sẽ không được hiển thị công khai. Các trường bắt buộc được đánh dấu *

HOTLINE 24/7: 098.234.5005 - 0967.40.70.80