Hướng Dẫn Cấu Hình MPLS QoS Trên Router Cisco

MPLS QoS Trên Router Cisco Là Gì?

Tính năng MPLS QoS (trước đây thường được gọi là tính năng MPLS CoS) trên các thiết bị Router Cisco cho phép quản trị viên mạng cung cấp các dịch vụ khác biệt trên mạng MPLS. Quản trị viên mạng có thể đáp ứng nhiều yêu cầu về mạng bằng cách chỉ định loại dịch vụ áp dụng cho từng gói IP được truyền. Các lớp dịch vụ khác nhau có thể được thiết lập cho các gói IP bằng cách đặt bit ưu tiên IP trong tiêu đề của mỗi gói.

MPLS QoS hỗ trợ các dịch vụ sau trên mạng MPLS:

  • Phân loại gói tin
  • Tránh tắc nghẽn
  • Quản lý tắc nghẽn

Bảng dưới đây mô tả các dịch vụ và chức năng của MPLS CoS.

Dịch Vụ Chức Năng QoS (CoS) Mô Tả
Phân loại gói tin CAR: Các gói được phân loại ở rìa mạng trước khi dán nhãn CAR sử dụng các bit loại dịch vụ (ToS) trong tiêu đề IP để phân loại các gói theo tốc độ truyền đầu vào và đầu ra. CAR thường được cấu hình trên các giao diện ở rìa mạng để kiểm soát lưu lượng truy cập vào hoặc ra khỏi mạng. Bạn có thể sử dụng các lệnh phân loại CAR để phân loại hoặc phân loại lại gói tin.
Tránh tắc nghẽn WRED: Các lớp gói được phân biệt dựa trên xác suất rớt WRED giám sát lưu lượng mạng để dự đoán và ngăn ngừa tắc nghẽn ở các nút cổ chai mạng và liên mạng chung. WRED có thể loại bỏ có chọn lọc lưu lượng ưu tiên thấp hơn khi giao diện bị tắc nghẽn; WRED cũng có thể cung cấp các đặc điểm hiệu suất khác biệt cho các loại dịch vụ khác nhau.
Quản lý tắc nghẽn WFQ cho nền tảng không phải GSR: Các lớp gói được phân biệt dựa trên các yêu cầu về băng thông và các đặc tính trễ hữu hạn.

MDRR cho các nền tảng GSR

WFQ là một hệ thống lập lịch trình tự động đảm bảo phân bổ băng thông hợp lý cho tất cả lưu lượng mạng. WFQ sử dụng các trọng số (mức độ ưu tiên) để xác định lượng băng thông mà mỗi loại lưu lượng được phân bổ.

MDRR, có chức năng tương tự như WFQ đối với các nền tảng không phải GSR, là sơ đồ ưu tiên lưu lượng ánh xạ lưu lượng IP tới các lớp hàng đợi dịch vụ khác nhau, dựa trên giá trị ưu tiên IP của từng gói. Các hàng đợi sau đó được phục vụ trên cơ sở quay vòng.


Cấu Hình MPLS QoS Trên Router Cisco

Hướng Dẫn Cấu Hình MPLS QoS Trên Router Cisco
Hướng Dẫn Cấu Hình MPLS QoS Trên Router Cisco

Cấu Hình WRED Cho MPLS QoS Trên Router Cisco

Dưới đây là các bước chi tiết để cấu hình WRED cho MPLS QoS trên Router Cisco:

  Lệnh hoặc Hành động Mục đích
Bước 1

enable

Ví dụ:

Device> enable

Bật chế độ EXEC đặc quyền

  • Nhập mật khẩu của bạn nếu được nhắc
Bước 2

configure terminal

Ví dụ:

Device# configure terminal

Vào chế độ cấu hình chung

Bước 3

interface type number

Ví dụ:

Device(config)# gigabitethernet0/0/0

Chỉ định loại và số giao diện, và vào chế độ cấu hình giao diện

Bước 4

random-detect

Ví dụ:

Device(config-if)# random-detect

Cấu hình giao diện để sử dụng phát hiện sớm ngẫu nhiên có trọng số/phát hiện sớm ngẫu nhiên có trọng số phân tán (WRED/DWRED).

Bước 5

random-detect precedence min-threshold max-threshold mark-probability

Ví dụ:

Device(config-if)# random-detect precedence 0 32 256 100

Cấu hình tham số WRED/DWRED cho mỗi giá trị ưu tiên.

Bước 6

end

Ví dụ:

Device(config-if)# end

Quay lại chế độ EXEC đặc quyền

Xác Minh Cấu Hình WRED Cho MPLS QoS Trên Router Cisco

Để xác minh WRED, hãy sử dụng lệnh có dạng trong bảng sau. Ví dụ này dựa trên “Device2” trong cấu trúc liên kết mạng được hiển thị trong hình trong phần Ví Dụ Cấu Hình bên dưới.

show queueing interface subinterface

Ví dụ:

Device2# show queueing interface gigabitethernet6/0/0

Xác minh cấu hình WRED trên giao diện được chỉ định

Device2# show queueing interface gigabitethernet6/0/0

Interface Gige6/0/0 queueing strategy:random early detection (WRED)
     Exp-weight-constant:9 (1/512)
     Mean queue depth:0

     Class   Random       Tail    Minimum    Maximum     Mark
               drop       drop  threshold  threshold  probability
       0         85          0         20         40     1/10
       1         22          0         22         40     1/10
       2          0          0         24         40     1/10
       3          0          0         26         40     1/10
       4          0          0         28         40     1/10
       5          0          0         31         40     1/10
       6          0          0         33         40     1/10
       7          0          0         35         40     1/10
      rsvp        0          0         37         40     1/10

Cấu Hình CAR Cho MPLS QoS Trên Router Cisco

Các bước chi tiết để cấu hình CAR cho MPLS QoS trên Router Cisco được thể hiện trong bảng dưới đây:

  Lệnh hoặc Hành động Mục đích
Bước 1

enable

Ví dụ:

Device> enable

Bật chế độ EXEC đặc quyền

  • Nhập mật khẩu của bạn nếu được nhắc
Bước 2

configure terminal

Ví dụ:

Device# configure terminal

Vào chế độ cấu hình chung

Bước 3

interface name

Ví dụ:

Device(config)# interface gigabitethernet

Chỉ định giao diện đầu vào và vào chế độ cấu hình giao diện.

Bước 4

rate-limit input [access-group [rate-limit ] acl-index] bps burst-normal burst-max conform-action conform-action exceed-action exceed-action

Ví dụ:

Device(config-if)# rate-limit input access-group 101 496000 32000 64000 conform-action set-prec-transmit 4

Chỉ định hành động để thực hiện trên các gói trong quá trình áp đặt nhãn.

Bước 5

end

Ví dụ:

Device(config-if)# end

Quay lại chế độ EXEC đặc quyền

Xác Minh Cấu Hình CAR Cho MPLS QoS Trên Router Cisco

Để xác minh CAR, hãy sử dụng lệnh sau:

show interfaces slot/port rate-limit

Ví dụ:

Device2# show interfaces fe1/1/1 rate-limit

Xác minh cấu hình CAR, sử dụng lệnh có dạng sau.

Device2# show interfaces fe1/1/1 rate-limit

FastEthernet1/1/1 
   Input
     matches:access-group 101
       params: 496000 bps, 32000 limit, 64000 extended limit
       conformed 2137 packets, 576990 bytes; action:set-prec-transmit 4
       exceeded 363 packets, 98010 bytes; action:set-prec-transmit 0
       last packet:11788ms ago, current burst:39056 bytes
       last cleared 00:01:18 ago, conformed 58000 bps, exceeded 10000 bps

Cấu Hình CBWFQ Cho MPLS QoS Trên Router Cisco

Bảng dưới đây thể hiện chi tiết các bước để cấu hình CBWFQ cho QoS trên Router Cisco

  Lệnh hoặc Hành động Mục đích
Bước 1

enable

Ví dụ:

Device> enable

Bật chế độ EXEC đặc quyền

  • Nhập mật khẩu của bạn nếu được nhắc
Bước 2

configure terminal

Ví dụ:

Device# configure terminal

Vào chế độ cấu hình chung

Bước 3

class-map class-map-name

Ví dụ:

Device(config)# class-map class-map-1

Tạo class map và vào chế độ cấu hình class-map.

Bước 4

match type number

Ví dụ:

Device(config-cmap)# match ip precedence 0 1

Chỉ định lưu lượng truy cập mà class map sẽ khớp.

Bước 5

policy-map policy-map-name

Ví dụ:

Device(config-cmap)# policy-map outputmap

Tạo policy map và vào chế độ cấu hình policy-map.

Bước 6

class class-map-name

Ví dụ:

Device(config-pmap)# class class-map-1

Liên kết class map với policy map.

Bước 7

bandwidth number

Ví dụ:

Device(config-pmap-c)# bandwidth 10000

Liên kết hành động băng thông (CBWFQ) để hoạt động trên lưu lượng phù hợp với class map và chuyển sang chế độ cấu hình policy-map class.

Bước 8

interface type number

Ví dụ:

Device(config-pmap-c)# interface gigabitethernet0/0/0

Chỉ định loại và số giao diện, và vào chế độ cấu hình giao diện.

Bước 9

service-policy output policy-map-name

Ví dụ:

Device(config-if)# service-policy output outputmap

Gán policy map cho một giao diện.

Bước 10

end

Ví dụ:

Device(config-if)# end

Quay lại chế độ EXEC đặc quyền.

Xác Minh Cấu Hình CBWFQ Cho MPLS QoS Trên Router Cisco

Để xác minh CBWFQ cho tính năng MPLS QoS hãy sử dụng lệnh sau:

show policy-map interface type number

Ví dụ:

Device5# show policy-map interface fe5/1/0

Xác minh cấu CBWFQdựa trên lớp, sử dụng lệnh có dạng sau. Ví dụ này dựa trên “Device 5” trong cấu trúc liên kết mạng được hiển thị trong hình trong phần ví dụ cấu hình.

Device5# show policy-map interface fe5/1/0

  FastEthernet5/1/0 
   service-policy output:outputmap
     class-map:prec_01 (match-all)
       522 packets, 322836 bytes
       5 minute rate 1000 bps
       match:ip precedence 0  1 
       queue size 0, queue limit 1356
       packet output 522, packet drop 0
       tail/random drop 0, no buffer drop 0, other drop 0
       bandwidth:class-based wfq, weight 10
       random-detect:
         Exp-weight-constant:9 (1/512)
         Mean queue depth:0
   Class Random       Tail    Minimum    Maximum     Mark      Output
           drop       drop  threshold  threshold  probability packets
   0          0          0       3390       6780     1/10         522
   1          0          0       3813       6780     1/10           0
   2          0          0       4236       6780     1/10           0
   3          0          0       4659       6780     1/10           0
   4          0          0       5082       6780     1/10           0
   5          0          0       5505       6780     1/10           0
   6          0          0       5928       6780     1/10           0
   7          0          0       6351       6780     1/10           0

     class-map:prec_23 (match-all)
       0 packets, 0 bytes
       5 minute rate 0 bps
       match:ip precedence 2  3 
       queue size 0, queue limit 0
       packet output 0, packet drop 0
       tail/random drop 0, no buffer drop 0, other drop 0
       bandwidth:class-based wfq, weight 15
       random-detect:
         Exp-weight-constant:9 (1/512)
         Mean queue depth:0
   Class Random       Tail    Minimum    Maximum     Mark      Output
           drop       drop  threshold  threshold  probability packets
   0          0          0          0          0    1/10            0
   1          0          0          0          0    1/10            0
   2          0          0          0          0    1/10            0
   3          0          0          0          0    1/10            0
   4          0          0          0          0    1/10            0
   5          0          0          0          0    1/10            0
   6          0          0          0          0    1/10            0
   7          0          0          0          0    1/10            0

     class-map:prec_45 (match-all)
       2137 packets, 576990 bytes
       5 minute rate 16000 bps
       match:ip precedence 4  5 
       queue size 0, queue limit 2712
       packet output 2137, packet drop 0
       tail/random drop 0, no buffer drop 0, other drop 0
       bandwidth:class-based wfq, weight 20
       random-detect:
         Exp-weight-constant:9 (1/512)
         Mean queue depth:0
   Class Random       Tail    Minimum    Maximum     Mark      Output
           drop       drop  threshold  threshold  probability packets
   0          0          0       3390       6780    1/10            0
   1          0          0       3813       6780    1/10            0
   2          0          0       4236       6780    1/10            0
   3          0          0       4659       6780    1/10            0
   4          0          0       5082       6780    1/10         2137
   5          0          0       5505       6780    1/10            0
   6          0          0       5928       6780    1/10            0
   7          0          0       6351       6780    1/10            0

     class-map:prec_67 (match-all)
       0 packets, 0 bytes
       5 minute rate 0 bps
       match:ip precedence 6  7 
       queue size 0, queue limit 0
       packet output 0, packet drop 0
       tail/random drop 0, no buffer drop 0, other drop 0
       bandwidth:class-based wfq, weight 25
       random-detect:
         Exp-weight-constant:9 (1/512)
         Mean queue depth:0
   Class Random       Tail    Minimum    Maximum     Mark      Output
           drop       drop  threshold  threshold  probability packets
   0          0          0          0          0    1/10            0
   1          0          0          0          0    1/10            0
   2          0          0          0          0    1/10            0
   3          0          0          0          0    1/10            0
   4          0          0          0          0    1/10            0
   5          0          0          0          0    1/10            0
   6          0          0          0          0    1/10            0
   7          0          0          0          0    1/10            0

     class-map:class-default (match-any)
       0 packets, 0 bytes
       5 minute rate 0 bps
       match:any 
         0 packets, 0 bytes
         5 minute rate 0 bps
       queue size 0, queue limit 4068
       packet output 90, packet drop 0
       tail/random drop 0, no buffer drop 0, other drop 0
Device5# 
Device5# show queueing interface fa1/1/0

Interface FastEthernet1/1/0 queueing strategy:VIP-based fair queueing
  FastEthernet1/1/0 queue size 0
         pkts output 2756, wfq drops 0, nobuffer drops 0
  WFQ:aggregate queue limit 13561 max available buffers 13561

      Class 0:weight 30 limit 4068 qsize 0 pkts output 97 drops 0 
      Class 2:weight 10 limit 1356 qsize 0 pkts output 522 drops 0 
      Class 3:weight 15 limit 0 qsize 0 pkts output 0 drops 0 
      Class 4:weight 20 limit 2712 qsize 0 pkts output 2137 drops 0 
      Class 5:weight 25 limit 0 qsize 0 pkts output 0 drops 0 \

Ví Dụ Cấu Hình MPLS QoS Trên Router Cisco

Các ví dụ về cấu hình dựa trên cấu trúc liên kết mạng mẫu được hiển thị trong hình bên dưới.

Hình 1. Cấu trúc liên kết mạng mẫu để định cấu hình MPLS CoS trên giao diện thiết bị

Ví Dụ: Cấu hình Cisco Express Forwarding

Cisco Express Forwarding phải chạy trên tất cả các thiết bị trong mạng MPLS để MPLS QoS hoạt động. Để bật Cisco Express Forwarding, hãy sử dụng một trong các lệnh sau:

Device(config)# ip cef

hoặc

Device(config)# ip cef distributed

Ví Dụ: Running IP Trên Device 1

Các lệnh sau bật định tuyến IP trên thiết bị 1. Tất cả các thiết bị trong hình phải được bật IP. Thiết bị 1 không phải là một phần của mạng MPLS.

!
ip routing
!
hostname R1
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.255
!
interface FastEthernet0/0/1
 ip address 10.0.0.1 255.0.0.0
!
router ospf 100
 network 10.0.0.0 0.255.255.255 area 100
 network 10.0.0.1 0.255.255.255 area 100

Ví Dụ: Running MPLS Trên Device 2

Thiết bị 2 là một label edge router. Cisco Express Forwarding và Multiprotocol Label Switching (MPLS) phải được bật trên thiết bị này. CAR cũng được định cấu hình trên Thiết bị 2 và giao diện Fast Ethernet 1/1/3. Chính sách CAR được sử dụng tại giao diện Fast Ethernet 1/1/0 hoạt động trên danh sách truy cập khớp với lưu lượng đến 101. Nếu tốc độ lưu lượng nhỏ hơn tốc độ thông tin đã cam kết (trong ví dụ này là 496000), lưu lượng sẽ được gửi với quyền ưu tiên IP 4. Nếu không, lưu lượng này sẽ được gửi với IP priority 0.

!
ip routing
!
hostname R2
!
ip cef
mpls ip
tag-switching advertise-tags
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!
interface FastEthernet1/1/0
 ip address 10.0.0.2 255.0.0.0
 rate-limit input access-group 101 496000 32000 64000 conform-action set-prec-transmit 4 exceed-action set-prec-transmit 0
!
interface POS6/0/0
 ip address 10.0.0.1 255.0.0.0
 mpls label protocol ldp
 mpls ip
 random-detect
 clock source internal
!
router ospf 100
 network 10.0.0.0 0.255.255.255 area 100
 network 10.1.0.0 0.255.255.255 area 100
 network 11.0.1.0 0.255.255.255 area 100
!
access-list 101 permit ip host 10.10.1.1 any 

Ví Dụ: Running MPLS Trên Device 3

Thiết bị 3 đang chạy MPLS. Cisco Express Fowarding và MPLS phải được bật trên thiết bị này.

!
ip routing
mpls ip
tag-switching advertise-tags
!
hostname R3
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!
interface POS0/1/0
 ip address 10.0.0.2 255.0.0.0
 mpls label protocol ldp
 mpls ip
 crc 16
!
interface POS3/0/0
 ip address 10.0.0.1 255.0.0.0
 mpls label protocol ldp
 mpls ip
 crc 16
 clock source internal
 tx-cos stm16-rx
!
router ospf 100
 network 10.0.1.0 0.255.255.255 area 100
 network 10.0.0.1 0.255.255.255 area 100
 network 10.1.0.0 0.255.255.255 area 100
!
cos-queue-group stm16-rx
 precedence 0 random-detect-label 0
 precedence 0 queue 0
 precedence 1 queue 1
 precedence 1 random-detect-label 1
 precedence 2 queue 2
 precedence 2 random-detect-label 2
 precedence 3 random-detect-label 2
 precedence 4 random-detect-label 2
 precedence 5 random-detect-label 2
 precedence 6 random-detect-label 2
 precedence 7 queue low-latency
 precedence 7 random-detect-label 2
 random-detect-label 0 250 1000 1
 random-detect-label 1 500 1250 1
 random-detect-label 2 750 1500 1
 queue 0 50
 queue 1 100
 queue 2 150
 queue low-latency alternate-priority 500

Ví Dụ: Running MPLS Trên Device 4

Thiết bị 4 đang chạy MPLS. Cisco Express Fowarding và MPLS phải được bật trên thiết bị này.

!
ip routing
mpls ip
tag-switching advertise-tags
!
hostname R4
!
interface Loopback0
 ip address 10.0.0.0 255.255.255.255
!
interface POS1/2/1
 ip address 10.0.0.1 255.0.0.0
 mpls label protocol ldp
 mpls ip
 crc 16
 clock source internal
 tx-cos stm16-rx
!
router ospf 100
 network 10.0.0.0 0.255.255.255 area 100
 network 10.1.0.0 0.255.255.255 area 100
 network 10.0.1.0 0.255.255.255 area 100
!
cos-queue-group stm16-rx
 precedence 0 queue 0
 precedence 0 random-detect-label 0
 precedence 1 queue 1
 precedence 1 random-detect-label 1
 precedence 2 queue 2
 precedence 2 random-detect-label 2
 precedence 3 random-detect-label 2
 precedence 4 random-detect-label 2
 precedence 5 random-detect-label 2
 precedence 6 random-detect-label 2
 precedence 7 queue low-latency
 random-detect-label 0 250 1000 1
 random-detect-label 1 500 1250 1
 random-detect-label 2 750 1500 1
 queue 0 50
 queue 1 100
 queue 2 150
 queue low-latency alternate-priority 200

Ví Dụ: Running MPLS Trên Device 5

Thiết bị 5 đang chạy Multiprotocol Label Switching (MPLS). Cisco Express Forwarding và MPLS phải được bật trên thiết bị này. Thiết bị 5 đã bật CBWFQ trên giao diện Fast Ethernet 5/1/0. Trong ví dụ này, class map được tạo, khớp các gói với các giá trị ưu tiên IP khác nhau. Các class map này sau đó được sử dụng trong policy map có tên là “outputmap”, trong đó CBWFQ được gán cho mỗi lớp. Cuối cùng, policy map được gán cho giao diện Fast Ethernet 5/1/0.

!
ip routing
mpls ip
tag-switching advertise-tags
!
hostname R5
!
!
class-map match-all prec_01
  match ip precedence 0  1 
class-map match-all prec_23
  match ip precedence 2  3 
class-map match-all prec_45
  match ip precedence 4  5 
class-map match-all prec_67
  match ip precedence 6  7 
!
!
policy-map outputmap
  class prec_01
    bandwidth 10000
    random-detect
  class prec_23
    bandwidth 15000
    random-detect
  class prec_45
    bandwidth 20000
    random-detect
  class prec_67
    bandwidth 25000
    random-detect
!
ip cef distributed
!
interface Loopback0
 ip address 10.0.0.0 255.255.255.255
 no ip directed-broadcast
!
interface POS1/1/0
 ip address 10.0.0.2 255.0.0.0
 ip route-cache distributed
 mpls label protocol ldp
 mpls ip
!
interface FastEthernet5/1/0
 ip address 10.0.0.1 255.0.0.0
 ip route-cache distributed
 full-duplex
 service-policy output outputmap
!
router ospf 100
 network 10.1.0.0 0.255.255.255 area 100
 network 10.0.1.0 0.255.255.255 area 100
 network 10.0.0.1 0.255.255.255 area 100

Ví Dụ: Running MPLS Trên Device 6

Thiết bị 6 đang chạy IP. Cisco Express Forwarding phải được bật trên thiết bị này. Thiết bị 6 không phải là một phần của mạng Multiprotocol Label Switching (MPLS)

!
ip routing
!
hostname R6
!
ip cef distributed
!
interface Loopback0
 ip address 10.0.0.0 255.255.255.255
!
interface FastEthernet2/0/0
 ip address 10.0.0.2 255.0.0.0
 ip route-cache distributed
 full-duplex
!
router ospf 100
 network 10.0.0.0 0.255.255.255 area 100
 network 10.1.0.0 0.255.255.255 area 100
!

Địa Chỉ Phân Phối Router Cisco Chính Hãng Giá Tốt Nhất

ANBINHNET ™ là nhà phân phối Cisco chính hãng, uy tín hàng đầu tại Việt Nam. Đến với chúng tôi, quý khách hàng sẽ nhận được những thông tin chính xác về nguồn gốc xuất xứ, giấy tờ, chứng chỉ, với mức giá Discount theo quy định của Cisco, đặc biệt hơn là hàng luôn sẵn kho số lượng lớn để đáp ứng nhu cầu của khách hàng.

ANBINHNET ™ có văn phòng giao dịch tại 2 thành phố lớn nhất là Hà Nội và Hồ Chí Minh (Sài Gòn), giúp mang lại sự thuận tiện cho khách hàng có nhu cầu mua thiết bị Cisco Router Chính Hãng có thể đến trực tiếp văn phòng của chúng tôi, cũng như rút ngắn thời gian giao hàng các sản phẩm Cisco Router Giá Tốt đến với khách hàng.

Để Nhận Thông Tin Hỗ Trợ Báo Giá Dự Án, Đặt Hàng, Giao Hàng, Bảo Hành, Khuyến Mại, Hỗ Trợ Kỹ Thuật của các sản phẩm Router CiscoHãy Chát Ngay với chúng tôi ở khung bên dưới hoặc gọi điện tới số hotline hỗ trợ 24/7 của ANBINHNET ™. Hoặc quý khách có thể liên hệ tới văn phòng của chúng tôi tại theo thông tin sau:

Địa Chỉ Phân Phối Router Cisco Chính Hãng Giá Tốt Tại Hà Nội

Địa Chỉ Phân Phối Router Cisco Chính Hãng Giá Tốt Tại Sài Gòn

Bài viết liên quan

Nhập Email để nhận ngay báo giá sản phẩm

    • Kết Nối Với Chúng Tôi